A Question about Backup and Restore

Question

I’ve recreated our SharePoint 2003 site to MOSS 2007 using SQL Server 2000, note that all services of MOSS 2007 is running in a single server including SQL 2000. Now I’ve backup MOSS 2007 (entire server farm) and tried restoring it to a new machine (MOSS 2007 using SQL Server 2008). The type of restore i used is New Configuration.

This is the error i’ve encountred:
Error: Object Shared Search Index failed in event OnRestore. For more information, see the error log located in the backup directory. InvalidOperationException: The new indexer must be enabled and installed

Any idea what went wrong.

My Response

The most probable reason for this error is that your Search Service was not running when you did your restore.  I am sure all other restore had gone successful other than search index.  Just configure your SharePoint Search Service and run a full crawl or redo the backup after starting the search. 

Final Response from the Guy

Thanks a lot for your guidance sir,
You are guru of share point, problem has resolved after stared the Search service it has restored successfully without any error and warning.

image001 

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s